It is currently Fri Apr 28, 2017 5:04 am



Welcome
Welcome to rfobasic

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. In addition, registered members also see less advertisements. Registration is fast, simple, and absolutely free, so please, join our community today. **You are not required to provide truthful information to any registration questions. Be whomever you wish to be.!


Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 118 posts ]  Go to page Previous  1 ... 7, 8, 9, 10, 11, 12  Next
Author Message
 Post subject: Re: RFO-BASIC! App Builder
Unread postPosted: Fri Sep 21, 2012 12:35 pm 
Offline
User avatar

Joined: Tue Jan 03, 2012 9:31 am
Posts: 5487
Location: Paris, France
Did you save the test.bas in /rfo-basic/source or maybe in /rfo-basic/source/samples ?
There is no reason for your test.bas to show in Windows and not in App Builder :|

_________________
- Creator of the Android BASIC! Compiler


Top
 Profile  
 
 Post subject: Re: RFO-BASIC! App Builder installation
Unread postPosted: Fri Sep 21, 2012 1:46 pm 
Offline

Joined: Mon Sep 17, 2012 4:12 pm
Posts: 14
hi, it is in source not in samples. ??
byg


Top
 Profile  
 
 Post subject: Re: RFO-BASIC! App Builder
Unread postPosted: Sat Sep 22, 2012 4:21 pm 
Offline
User avatar

Joined: Thu May 26, 2011 3:52 pm
Posts: 282
now i got it to work even with android 2.1:
- changing android-manifest in rfo-app-builder dir
does not work, because it will be erased at next
build
- changing android-manifest directly in myapp.zip
and disabling download of current version works

@paul: could you set min-sdk-version to 7 in the
current myapp.zip file ?
@mougino: i recognize that some questions appears
again and again in this thread. it would be nice to
have a quintessence of them as a-z help directly
in app builder (e.g. how to set bas dir, write perms,
where to put app builder dir on win 7/8 ...)

thanks, oliver


Top
 Profile  
 
 Post subject: Re: RFO-BASIC! App Builder
Unread postPosted: Mon Sep 24, 2012 7:03 pm 
Offline

Joined: Sat May 26, 2012 12:33 pm
Posts: 44
Can anyone help me compile my app using app builder. App builder is all set and running, problem is when it is at the final step of compiling the program.

Here's the error log

-set-mode-check:

-set-release-mode:

-release-obfuscation-check:
[echo] proguard.config is ${proguard.config}

-check-env:
[checkenv] Android SDK Tools Revision 21
[checkenv] Installed at C:\Documents and Settings\chris\My Documents\Downloads\android-sdk

-setup:
[echo] Project Name: Basic
[gettype] Project Type: Application

-build-setup:
[echo] Resolving Build Target for Basic...
[gettarget] Project Target: Android 2.1
[gettarget] API level: 7
[echo] ----------
[echo] Creating output directories if needed...
[echo] ----------
[echo] Resolving Dependencies for Basic...
[dependency] Library dependencies:
[dependency] No Libraries
[dependency]
[dependency] ------------------
[dependency] API<=15: Adding annotations.jar to the classpath.
[echo] ----------
[echo] Building Libraries with 'release'...
[subant] No sub-builds to iterate on

-pre-build:

-code-gen:
[mergemanifest] Merging AndroidManifest files into one.
[mergemanifest] Manifest merger disabled. Using project manifest only.
[echo] Handling aidl files...
[aidl] No AIDL files to compile.
[echo] ----------
[echo] Handling RenderScript files...
[renderscript] No RenderScript files to compile.
[echo] ----------
[echo] Handling Resources...
[aapt] Generating resource IDs...
[aapt] C:\Documents and Settings\chris\My Documents\test\MyNwApp100\res\values\styles.xml:65: error: Error: No resource found that matches the given name: attr 'android:textCursorDrawable'.

BUILD FAILED
C:\Documents and Settings\chris\My Documents\Downloads\android-sdk\tools\ant\build.xml:633: The following error occurred while executing this line:
C:\Documents and Settings\chris\My Documents\Downloads\android-sdk\tools\ant\build.xml:669: null returned: 1

Total time: 1 second


Top
 Profile  
 
 Post subject: Re: RFO-BASIC! App Builder
Unread postPosted: Tue Sep 25, 2012 2:30 am 
Offline
User avatar

Joined: Tue Jan 03, 2012 9:31 am
Posts: 5487
Location: Paris, France
Hello godgrid,

This error "android:textCursorDrawable" is also currently met by jbrasfield as well, he sent me his program and resource files and I tried to replicate but everything works OK on my side :( it means so far I haven't found the solution, so I asked him to try some workaround. In the meantime could you please answer the questions below:
- OS and version of your system (Win XP, 7 etc.)
- are you using 32 bits or 64 bits architecture?
- path of where "rfo-basic app builder.exe" and zlib.dll have been placed
- version of your App Builder
- if you run App Builder with admin privileges or not (under Win7/8/Vista)
- if you are in online mode or offline mode in App Builder
- what version of Basic! you are using (showed in the online/offline mode bar of App Builder)
- a ctrl+c/ctrl+v of your path for "Output folder" in App Builder
- a ctrl+c/ctrl+v of your path for "Main .bas file" in App Builder

It is a real pity I cannot replicate this error on my side, I would use Eclipse to dig and see what's wrong (same of what I did while developping App Builder). Ifever you have the possibility to install Eclipse+ADT and investigate (see what error is thrown and where and why it occurs), it would be of a huge help for other users in the same situation.

_________________
- Creator of the Android BASIC! Compiler


Top
 Profile  
 
 Post subject: Re: RFO-BASIC! App Builder
Unread postPosted: Tue Sep 25, 2012 3:31 am 
Offline

Joined: Mon Sep 17, 2012 4:12 pm
Posts: 14
Hi, That is my problem also, here is my setup

- OS and version of your system (Win XP, 7 etc.)
Windows 7 with all the latest update
- are you using 32 bits or 64 bits architecture?
not sure, it is a 64 bits
- path of where "rfo-basic app builder.exe" and zlib.dll have been placed
C:\rfo
- version of your App Builder
version 0.8
- if you run App Builder with admin privileges or not (under Win7/8/Vista)
I tried both, no difference
- if you are in online mode or offline mode in App Builder
online
- what version of Basic! you are using (showed in the online/offline mode bar of

App Builder)
version 1.65
- a ctrl+c/ctrl+v of your path for "Output folder" in App Builder
c:\rfo
- a ctrl+c/ctrl+v of your path for "Main .bas file" in App Builder
F:\rfo-basic\source\test1.bas
byg


Top
 Profile  
 
 Post subject: Re: RFO-BASIC! App Builder
Unread postPosted: Tue Sep 25, 2012 4:38 am 
Offline
User avatar

Joined: Tue Jan 03, 2012 9:31 am
Posts: 5487
Location: Paris, France
Hi byg, I don't see anything wrong with your configuration.
I'm suspecting the problem is due to the Java chain and not related to App Builder.
Could you ctrl+c/ctrl+v your full JDK path, your full Android SDK path, and your full Apache Ant path (from App Builder Guide (aka A-Z) screen)
I will also need the specificities of the target you installed in Android SDK Manager: "Android n.n (API N)"
Thanks!

_________________
- Creator of the Android BASIC! Compiler


Top
 Profile  
 
 Post subject: Re: RFO-BASIC! App Builder
Unread postPosted: Tue Sep 25, 2012 7:02 am 
Offline

Joined: Sat May 26, 2012 12:33 pm
Posts: 44
everything was installed on c:\....\...\...\downloads
-app-builder v0.8
-zlib.dll
-android-sdk
-ant v1.84

except for JDK whose path I wasnt able to copy, but I think it was installed in c:\...\windows.

-App-builder is not run with admin priveleges
-run on windows xp pro, novo laptop, I'm assuming 32bit
-myapp.zip 1.64 offine mode
-installed api 14 and 7
-.bas source path =c:\...\downloads\sdcard\rfo-basic\source\myfile.bas


ps. I DON'T OWN THE LAPTOP :)


Top
 Profile  
 
 Post subject: Re: RFO-BASIC! App Builder
Unread postPosted: Tue Sep 25, 2012 10:24 am 
Offline

Joined: Sat May 26, 2012 12:33 pm
Posts: 44
by the way, my program doesnt require any additoinal data, so data and database folders are empty. But app-builder requires me to define resources, to resolve this I made a blank txt file then moved it to required resources (right screen of the resources window) then back again to (left screen of resources window)


Top
 Profile  
 
 Post subject: Re: RFO-BASIC! App Builder
Unread postPosted: Tue Sep 25, 2012 4:03 pm 
Offline

Joined: Mon Sep 17, 2012 4:12 pm
Posts: 14
Hi Mougino
Here is a copy of my rfo-basic app builder.ini file

[LastFolders]
output=C:\rfo\
main=F:\rfo-basic\source\test1.bas
[LastApp]
name=My New App
version=1.00
[Settings]
jdk_path=C:\Program Files (x86)\Java\jdk1.7.0_03
android_sdk_path=C:\android
ant_path=C:\apache-ant-1.8.4

I started android sdk manager and here what it says
android 4.1 (api16)
4.0.3(api15)
4.0 (api14)
all above are marked installed.
again thanks for the help.
Byg


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic This topic is locked, you cannot edit posts or make further replies.  [ 118 posts ]  Go to page Previous  1 ... 7, 8, 9, 10, 11, 12  Next


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
suspicion-preferred