It is currently Sat Apr 29, 2017 8:15 pm



Welcome
Welcome to rfobasic

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. In addition, registered members also see less advertisements. Registration is fast, simple, and absolutely free, so please, join our community today. **You are not required to provide truthful information to any registration questions. Be whomever you wish to be.!


Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Run statement doesn't work anymore?
Unread postPosted: Thu Mar 16, 2017 2:46 am 
Offline

Joined: Sat Mar 15, 2014 3:54 am
Posts: 88
I am developing my programs with BlueStacks in Windows10
A few days ago Rfo-basic v01.90 was replaced by v01.91
I didn't ask for it, but okee.

I have the following situation:
-> sdcard/rfo-basis/source/HexEdit/HexEdit.bas
I run this program from another program:
-> run "HexEdit/HexEdit.bas"
In Version 01.90 this worked fine
In Version 01.91 i get the error message:
-> hexedit/hexedit.bas not found

I changed HexEdit/HexEdit to hexedit/hexedit.bas
but got the same result
Am i doing something wrong?

Regards, Tom


Top
 Profile  
 
 Post subject: Re: Run statement doesn't work anymore?
Unread postPosted: Thu Mar 16, 2017 5:57 am 
Offline
User avatar

Joined: Tue Jan 03, 2012 9:31 am
Posts: 5487
Location: Paris, France
Hi Tom,

There were changes in the RUN command so it seems running a bas file from a subfolder is broken...

Have you tried putting all bas files directly in rfo-basic/source, as BASIC! does ?

Nicolas

_________________
- Creator of the Android BASIC! Compiler


Top
 Profile  
 
 Post subject: Re: Run statement doesn't work anymore?
Unread postPosted: Thu Mar 16, 2017 5:59 am 
Offline
User avatar

Joined: Tue Jan 03, 2012 9:31 am
Posts: 5487
Location: Paris, France
GitHub issue #233 created

_________________
- Creator of the Android BASIC! Compiler


Top
 Profile  
 
 Post subject: Re: Run statement doesn't work anymore?
Unread postPosted: Wed Mar 22, 2017 12:48 am 
Offline

Joined: Sat Mar 15, 2014 3:54 am
Posts: 88
Hi Nicolas

I have a separate directory for each of my projects.
I tried run "prog.bas" and that works fine.

Tom


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
suspicion-preferred